Instalar Mountain Lion

Instalar Mac OS X 10.8 Mountain Lion en Gigabyte P55-USB3 (UniBeast + MultiBeast)

Tonymacx86 y Macman nos proponen un método de instalar Mountain Lion (ML en adelante) en una serie de placas base compatibles de las marcas Gigabyte y Asus, con procesadores Intel que van desde Core 2 Duo hasta los recientes Ivy Bridge pasando por los primeros i3, i5 e i7 y la generación posterior Sandy Bridge.

La placa referenciada en este artículo es el modelo Gigabyte P55-USB3 (audio ALC892 y red Realtek RTL 8111E) con micro Core i5 750 y gráfica Radeon 6850 de 1gb.

Encontrarás información detallada sobre el método de instalación y las herramientas utilizadas en foros y blog del sitio tonymacx86.

1. Comprar ML en la tienda de Apple

ML ha de ser comprado desde la aplicación Mac App Store y solamente cuesta 16€. Se descarga en la carpeta /Aplicaciones con el nombre “Instalar OS X Mountain Lion”. Ahí es donde lo buscará UniBeast más adelante.

2. Descargar UniBeast y MultiBeast

Ambos desde el sitio tonymacx86. Las versiones utilizadas han sido UniBeast 1.5.2 y MultiBeast 5.0.1, ambas específicas de ML.

3. Preparar la memoria USB

Con Utilidad de Discos hay que formatear una memoria USB de al menos 8gb de tamaño con el formato “Mac OS Plus (con registro)” pero recuerda crear en ella previamente la partición con esquema MBR porque el esquema GUID propio de Apple suele impedir que las unidades USB arranquen bien en muchas placas Gigabyte. Puedes darle el nombre que desees, por ejemplo “USB”.

4. Crear en la memoria USB una copia de ML

Ahora es el momento de ejecutar UniBeast, teniendo ML en la carpeta /Aplicaciones y la memoria USB montada en el Escritorio:

  • en las opciones de UniBeast marca “Legacy USB support”
  • al terminar (tarda varios minutos) tendrás en la memoria USB una copia de ML desde la que arrancar el PC para proceder a su instalación
  • ejecuta este comando en Terminal para mostrar los archivos ocultos en el Finder:
    defaults write com.apple.finder AppleShowAllFiles TRUE;killall Finder
  • copia a la carpeta /Extra de la memoria USB un DSDT válido (sirve el que ya usas en Lion, también puedes conseguirlo en la sección DSDT del sitio tonymacx86)
  • revisa el archivo /Extra/org.chameleon.boot.plist de la memoria USB, en mi hardware estas son las opciones que mejor resultado dan:
    <key>Boot Banner</key>
    <string>No</string>
    <key>GUI</key>
    <string>No</string>
    <key>GraphicsEnabler</key>
    <string>No</string>
    <key>Instant Menu</key>
    <string>Yes</string>
    <key>Kernel Flags</key>
    <string></string>
    <key>Legacy Logo</key>
    <string>Yes</string>

5. Instalar ML desde la memoria USB

Arranca el PC desde la memoria USB (pulsa F12 para mostrar el menú de selección de dispositivos de arranque en placas Gigabyte) e instala ML en el destino deseado, puede ser una partición en blanco o un sistema con Lion que se actualizará a ML.

Al terminar, arranca de nuevo desde la memoria USB pero elige como destino la partición con ML recién instalado.

6. Ejecutar MultiBeast

Las opciones que selecciono son:

  • UserDSDT install (coloca el archivo DSDT.aml en el Escritorio) si no lo copiaste a la memoria USB antes de instalar ML
  • System Utilities
  • ALC8xxHDA for legacy… (versiones no recientes de ALC888, ALC888b/887, ALC889, ALC889a/885, ALC892 o ALC898)
  • Patched AppleHDA (ALC892)
  • IOAHCIBlockStorageInjector
  • 3rdParty SATA
  • FakeSMC (imprescindible)
  • FakeSMC plugins (Motherboard plugins + HWMonitor application)
  • AppleRTC patch for CMOS reset
  • Lnx2mac’s Realtek RTL81xx Ethernet
  • Chimera 1.10
  • 64-bit GraphicsEnabler=No
  • Generate CPU States
  • Use kernel cache
  • System definition iMac 12,1
  • Extension migration tool

7. Reiniciar el PC sin la memoria USB.

OBSERVACIONES


Tarjetas gráficas Radeon de la serie 6xxxx

Las tarjetas gráficas Radeon de la serie 6xxx presentan un problema que impide a la memoria USB arrancar correctamente, algunos usuarios lo han resuelto simplemente configurando el modificador GraphicsEnabler del archivo /Extra/org.chameleon.boot.plist de la memoria USB en No. Si con ésto no es suficiente:

  • haz copia de seguridad de la extensión ATI6000controller.kext que está en la carpeta /System/Library/Extensions de la memoria USB (la necesitarás de nuevo cuando ML esté instalado) y bórrala
  • el modificador GraphicsEnabler del archivo /Extra/org.chameleon.boot.plist de la memoria USB ha de estar en No
  • cuando ML arranque ya instalado lo hará con resolución de pantalla básica, instala con Kext Wizard, en la carpeta /System/Library/Extensions, la extensión ATI6000controller.kext que guardaste anteriormente
  • ejecuta en Terminal el comando “sudo touch /System/Libray/Extensions”
  • el modificador GraphicsEnabler del archivo /Extra/org.chameleon.boot.plist de ML puede cambiarse a Yes para tener aceleración gráfica completa
  • reinicia el PC.

Tienes información detallada sobre la instalación de esta tarjeta en Lion en 2 artículos anteriores: Radeon 6850 (1) y Radeon 6850 (2).

Si usas tarjeta gráfica nVidia no es necesario realizar esta tarea, la mayoría de las tarjetas con chip nVidia suelen funcionar bien simplemente con poner el modificador GraphicsEnabler del archivo /Extra/org.chameleon.boot.plist de ML en Yes.


Si el sistema se cuelga al arrancar cuando aparece la línea “PCI Configuration Begin” lee este artículo para solucionarlo.


Si falla la opción de MultiBeast “AppleRTC patch for CMOS reset” y el PC resetea su BIOS cuando reinicias después de haber entrado en el modo de reposo y salido de él, ejecuta en Terminal:

sudo perl -pi -e 's|x75x30x89xd8|xebx30x89xd8|' /System/Library/Extensions/AppleRTC.kext/Contents/MacOS/AppleRTC

Si tienes un error al arrancar DVD Player que se manifiesta en un mensaje de que no hay dispositivo válido y en que, si usas teclado Apple, el botón Eject no funciona, busca información ampliada en el hilo titulado “Eject button in ML” en el foro de tonymacx86, este problema parece estar relacionado con un mal reconocimiento de la conexión SATA del DVD, por ahora las opciones para solucionarlo son:

  • usar la aplicación DVDDriveSwitcher que cambia la configuración del DVD como Interno o como Externo, corrige el error de DVD Player pero no el del botón Eject
  • instalar la extensión AHCI_3rdParty_SATA.kext que corrige ambas cosas (es la opción “3rdParty SATA” de MultiBeast pero desde el hilo “Eject button in ML” puedes descargar una versión modificada que parece dar mejor resultado).

En mi PC la gráfica Radeon 6850 funciona muy bien con GraphicsEnabler en No y la inyección de código específico de esta tarjeta, creado por el usuario Hard233, que ha de ir colocado en la sección Device (PCI0) así.


AVISO: las instrucciones y propuestas de esta página se proporcionan sin garantía de ningún tipo a la hora de llevarlas a la práctica. Lo que ha funcionado bien en mi caso pudiera no hacerlo en el tuyo.

Anuncios

92 pensamientos en “Instalar Mountain Lion

  1. Hola Miliuco, pude solucionarlo de otra forma. Igual muchas gracias.

    Por ahora en cuestión de graficos va bien pero he tenido que instalar Multibeast con la opción GraphicsEnabler=No ¿esto realmente podría repercutir en la calidad de imagen? Es decir, ¿el hecho que no haya ningún controlador influye en algo? Soy fotógrafo y me importa bastante ese asunto.

    El driver de red ok. Del audio no me reconoce dispositivo alguno seguiré intentando. ¿Tú sabes por qué podría estar pasando esto?
    Gracias! Es muy difícil encontrar ayuda en español!

  2. Pero, Héctor, comenta cómo lo arreglaste para que nos sirva a otros, solamente con decir ya lo arreglé no es útil para los demás.

    La guía que has seguido para instalar ML en placas Intel DX58so es lo suficientemente completa para conseguirlo con éxito, y respecto al sonido es raro porque parece un chip bastante compatible, siguiendo las instrucciones de la guía debería funcionar bien.

  3. Hola de nuevo! Lo que hice fue descargarme el DSDT auto patcher de acá . Ejecuté el archivo .jar del programa y generé, con el parche incluido en la carpeta, el archivo DSDT.aml para mi placa. Una vez hecho esto instalé Multibeast de la forma más normal. Seleccioné UserDSDT y reinicié.

    Cuando reinicié me apareció la pantalla en negro nuevamente. Entré con el flag GraphicsEnabler=No, fui a Multibeast > Drivers > Bootlooaders, busqué la casilla para poder bootear siempre en con ese flag. Eso fue todo. Pensaba hacer un tuto cuando tenga todo funcionando :)

    Por ahora el audio sigue sin funcionar y, cuando “reposo” la máquina, se apaga el monitor pero se escucha todo lo demás trabajando (ventiladores etc.). Tengo esas dos cosas pendientes. He probado ya con uno y otro driver de Multibeast pero nada.

    Ah y bueno sigo con la duda sobre si la ausencia de un controlador de video influya en la calidad final de los gráficos.

    Espero haber aportado algo :) Si sabes algo con respecto a mis dudas soy todo ojos.

    Un abrazo y saludos!

  4. Buena solución la de crearte el DSDT para tu placa. El reposo es una de las cosas más difíciles de conseguir junto con SpeedStep del procesador (tener varios estados de carga según los requerimientos del sistema). Sólo sistemas muy compatibles y más aún si son recientes entran y salen del reposo correctamente. Por si acaso revisa en BIOS el modo de reposo (sleep) que tienes configurado, si es S1 no apaga por completo la máquina, si es S3 sí la apaga del todo pero éso no garantiza que en OSX funcione bien.

    En cuanto al sonido, si usas DSDT sigue los pasos básicos de MultiBeast. Marcas ALC8xx, eliges ALC889 (creo que es el que lleva tu placa, si no es ése coges el adecuado) y, dependiendo de si has incluido en DST código de sonido HDEF, eliges HDA Enabler o no, sin código HDEF en DSDT añades HDA Enabler pero el que se corresponda con tu chip de audio.

    Si arrancas con GraphicsEnabler=No solamente significa que Chameleon (Chimera) no va a intentar reconocer la tarjeta que tienes y no va a cargar código para esa tarjeta pero no es sinónimo de no tener gráficos en condiciones, depende de si OSX reconoce bien tu tarjeta o no.
    Algunas indicaciones de si la tienes bien instalada son:
    – en Perfil de Sistema sale como el modelo correcto
    – acepta la resolución nativa del monitor
    – el puntero del ratón tiene sombra
    – las aplicaciones Chess (Ajedrez) y DVD Player funcionan bien
    – en Dashboard si añades un widget se muestran ondulaciones de la pantalla
    – puedes poner translúcida la barra de menús del Escritorio.
    Prueba estas cosas.
    ¿En qué puerto de la tarjeta gráfica conectas el monitor? ¿has probado a cambiar de puerto?

  5. Hola, con respecto a la gráfica comprobé todo lo que me dijiste y parece ir muy bien. Con el audio pues no logro hacerlo funcionar :(

    Estuve leyendo algo sobre la opción reposo y efectivamente parece algo bastante complicado de hacer funcionar, sobre todo si, como en mi caso, no se sabe mucho de editar kext y esas cosas un poco más complejas.

    Seguiré probando a ver qué sucede! Igual cualquier progreso lo postearé por acá! Gracias por la ayuda nuevamente.

    Un abrazo.

  6. Lo del audio parece raro, desde luego, en caso de que lo necesites y no consigas ponerlo en marcha puedes recurrir a dispositivos USB que funcionan en OSX prácticamente todos, puede ser dispositivo de audio USB al que conectar los atavoces o pueden ser altavoces que recogen el sonido directamente desde el puerto USB por bluetooth, consulta en sitios como tonymacx86 o insanelymac productos que ya estén probados pero ya te digo que sería raro que un audio USB no funcionase en OSX sin necesidad de instalar drivers ni nada.

  7. Hola, reinstalé todo como lo había hecho antes y esta vez para activar al audio recurrí a este hilo. Sólo bajé ML_AppleHDA-889-Alpha.zip, jalé los archivos a mi escritorio, y con KextBeast instalé los ktext.

    Reinicié y funcionó todo :) Red, video, audio e incluso puedo ir al reposo por lo que asumo que algo he tenido que haber hecho mal la vez anterior.

    Igual tengo un par de dudas. Cuando bajo el volumen a veces se escucha un pitido por uno de los parlantes. Es mínimo pero esta allí. La solución es mover el control de volumen y desaparece. A veces el pitido después de mover el control no desaparece sino que se va al otro parlante, entonces lo muevo de nuevo y se va. ¿Quizá tenga que ver con no haber seguido estos pasos?

    For all users
    1. With DSDT
    a. edit your dsdt for Mountain Lion Audio/layout-id 1 before you install the Mountain Lion Patched AppleHDA
    .

    La verdad es que no entiendo mucho sobre editar ésto. Gracias y saludos.

    • Ese artículo de Toleda supone un enfoque reciente, ya ves que en ML cuesta más que antes poner el audio Realtek en marcha. Toleda es actualmente uno de los mayores (o el mayor) experto en este tema.

      No sé si ese ruido tiene que ver con DSDT, en el artículo pone:

      For all users
      1. With DSDT
      a. edit your dsdt for Mountain Lion Audio/layout-id 1 before you install the Mountain Lion Patched AppleHDA.
      2. Without DSDT,
      a. delete current S/L/E/HDAEnabler8??.kext and install HDAEnabler1.kext with the Mountain Lion Patched AppleHDA.

      Como ves hay opción para DSDT y sin DSDT. Aquí tienes instrucciones para añadir HDEF en DSDT pero si te sientes inseguro sobre ello mándame tu DSDT actual al email que verás en https://perez987.wordpress.com/info/ y te lo devolveré con el único añadido de código HDEF con layout.id=1 tal como propone Toleda.

  8. Hola, sólo para estar seguro, ¿el DSDT.aml es mejor si te lo paso antes o después de ejecutar Multibeast?

    Tengo que contarte algo más. Ayer por curiosidad reinstalé todo. pensando que las dos últimas veces pude haber hecho algo mal y bueno, no fue necesario usar los Kext de Toleda.

    Solamente generé mi DSDT.aml hice todo como antes (con network y gráficos) pero para audio esta vez me fui a whitout DSDT y clické la casilla de ALC889. No se por qué funcionó allí, si se supone que tengo ya un DSDT. La cosa es que funciona, sí, pero con el mismo problema del ruidito. Exactamente igual que cuando parchée con el método de Toleda.

    Eso quiere decir que no importa el método pues el problema persiste :( Ahora ¿sería útil añadirle todas formas los HDEF? ¿Qué función cumplen estos exactamente?

    No tienes idea de cuánto me has ayudado Miliuco!! muchas gracias!!!

  9. HDEF permite que los chips de audio Realtek que solemos tener en los Hackintosh puedan funcionar, lo que hace es inyectar en el arranque un código que permite reconocer el audio, la misma función cumplen los archivos HDAEnabler, se puede usar uno u otro indistintamente.
    No parece que vaya a servir de algo añadir HDEF al DSDT pero por probar… El DSDT que necesito es el que usas cuando ya tienes el sistema en marcha, el que generas o has generado para tu sistema.

  10. Ok! el único que conozco es el que se genera en mi escritorio. Te envío ese en unas horas que ahora estoy en otro lado. Saludos.

  11. Hola, Miliuco. Gracias nuevamente por la ayuda. Probé con los DSDT y lo comparé el mío pero no ha mejorado :(
    Mi compu funcionaba con unos parlantes “autoamplificados”, para asegurarme que no fueran ellos la causa del problema probé con otros, unos genéricos.

    Con estos parlantes “genéricos” (sin amplificación) me di cuenta que el volumen de salida es muy bajo, casi ni se escucha. Comparando mi Macbook con estos mismos parlantes obtengo un volumen muchísimo mayor.

    Por allí me recomendaron probar los drivers Vodoo HDA. Me gustaría primero borrar el que ya instalé. No tengo idea de cómo hacerlo.

    Muchas gracias!

    • Con el PC necesitas altavoces amplificados, lo que cuentas del volumen es normal. Puedes probar VoodooHDA que además viene en MultiBeast. Si instalas VoodooHDA has de borrar otros controladores de sonido, busca en /S/L/E las extensiones Alc8xx… y HDAEnabler… y algunos borran también la básica HDA de Apple que se llama AppleHDA.kext.

  12. Hola, saludos a todos… Bueno, la verdad soy nuevo en esto de hakintosh, tengo una pc portátil Compaq c700 con un procesador intel core2 duo t5250 1.5ghz, 2gb de ram ddr2, dd 120gb. He preparado un USB con Lion retail y multibeast… al bootear en mi laptop muestra la pantalla negra con la opción para windows, la partición que creé para OSX y el instalador del USB pero al tratar de comenzar la instalación carga la pantalla con la manzana por 2 seg y aparece un mensaje que dice que debo reiniciar mi computadora (el mensaje sale por encima de unos comandos que salen en la pantalla blanca)… por favor, necesito ayuda.

    • Hola, desconozco ese portátil por lo que has de buscar ayuda en los foros apropiados. Por lo poco que sé, hay gente que ha conseguido instalar Lion aunque la wireless no funciona si no se modifica (hackea) la BIOS y también cuesta que funcionen teclado y ratón.
      Prueba la distribución iAtkos L2 que viene preparada para hardware más amplio y elige el driver Voodoo PS2 para ver si tienes teclado y puntero cuando arranques.

  13. Tengo un Dell Inspiron 580 corriendo Mountain Lion perfecto, salvo por el audio. Mi controladora es una alc887 y no hay forma de hacerla funcionar. Lo más cerca que estuve fue con una controladora que metí manual (voodooHDA.kext) que funcionó pero al reiniciar el ordenador daba kernel panic, con lo que la tuve que quitar. Con MultiBeast seleccionando alc888/887 with/without DSDT me da error de instalación y no funciona.

    Gracias por la ayuda.

    • Algunos usuarios han instalado ML en ese ordenador sin grandes problemas, incluso en tonymacx86 hay reseñas de algunos casos, lo poco que he leído sobre ello es que suele ser suficiente instalar alc888/887 desde MultiBeast para tener el audio funcionando.
      Cuando dices with/without DSDT supongo que tienes DSDT modificado para tu chip de sonido ¿no? En caso de duda puedes elegir HDAEnabler para alc888/887 para garantizar que se inyecta el código adecuado en el arranque.

  14. Hola, Miliuco. Gracias por toda la ayuda brindada, recién tengo el tiempo de escribir. Mi problema con el sonido raro desapareció sólo. O mejor dicho me di cuenta que no estaba días después de haber ordenado mis cables y haber conectado algunos enchufes en otros toma corrientes.
    Supongo que puede que tenga que ver.
    Si llego a terminar el tutorial para mi modelo de placa lo posteo por acá. Un abrazo y gracias de nuevo.
    Saludos!

  15. Sí, he probado tanto legacy como current.
    “…supongo que tienes DSDT modificado para tu chip de sonido ¿no?…” Ni idea de dónde o cómo se mira eso.
    Gracias de nuevo por tu ayuda.

    • Modificar DSDT para audio está más allá de este artículo y hay varios sitios en la red donde consultarlo. De cualquier manera, si eliges la opción “without DSDT” ya viene diseñada para quienes no han modificado el DSDT por lo que debería funcionar en tu caso independientemende de cómo tengas el DSDT.
      Si miras en Preferencias de sistema > Sonido ¿sale algún dispositivo de sonido en las pestañas Entrada y/o Salida?

  16. El DSDT no lo he tocado porque no sé cómo hacerlo. Sin DSDT tampoco instala nada. El MultiBeast con el audio me da siempre error al acabar. En preferencias de sonido no aparece nada en entrada y salida.

  17. Hola a todos, muchas gracias por vuestros aportes.
    Tengo un pc de sobremesa Dell Inspiroin 580 i3, he conseguido instalar iAtkos L1 pero no hay manera de conseguir funcionar la tarjeta de red integrada, ni el audio integrado ni la resolución óptima de una Ati 5500??? He probado de todo, alguna ayuda o idea de cómo lo puedo hacer?? Gracias de antemano.

  18. Si buscas más arriba verás varios comentarios de Ales Pardo que tiene un PC similar, la guía que hay en tonymacx86 con el título “(SUCCESS) Dell Inspiron 580 Mountain Lion” parece lo más destacado que he visto por ahí, poco más te puedo decir ya que no conozco de cerca ese ordenador.

  19. Muchas gracias por tu ayuda, he conseguido el audio y también la gráfica ATI 5450 perfecto todo exepto la red, no hay manera, tengo la BCM57887 según informe de sistema, probé con 5722D y me pone (Just place it in the Plugins folder of IONetworkingFamily and “install” it using Kext Wizard or something), yo lo instalo con Kext wizard como siempre pero nada, habrá que colocarlo en la carpeta esa?? cómo es ??? no atino, alguna luz??? Gracias de antemano.

  20. Gracias por todo, resultó el tema: por si alguien no lo sabe, hay que colocar BCM5722D dentro de la carpeta Plugins de IONetworkingFamily.kext, luego instalar con Kext wizard, reiniciar … y VOILA.

    • Hola, te he leído cuando ya lo habías arreglado solo pero así es, algunos de esos controladores de tarjetas de red van como Plugins dentro del controlador madre IONetworkingFamily.kext, ya verás que sucede con más archivos KEXT que tienen a su vez otros dentro de su carpeta Plugins.
      Enhorabuena.

  21. Hola, me presento, tengo el siguiente equipo:

    Placa Base Gigabyte x79 UD5
    Procesador intel i7 3820
    Memoria RAM 4×8 GB DDR3 corsair
    Tarjeta gráfica Gigabyte 660 TI 3GB
    Disco duro SSD OCZ Agility4 256 GB

    He realizado una instalación de Mountain Lion desde un Macbook Pro al disco SSD conectado a través de USB con un adaptador, la instalación se realiza correctamente, seguido actualizo a la versión 10.8.2, todo correcto, paso Multibeast con el DSDT correspondiente, al meter el SSD en el ordenador mencionado arriba y arrancar con -v se queda en el arranque con la siguiente información como última línea:

    mac framework successfully initialized
    using 16384 buffer headers and 10240 cluster IO buffer header.

    ¿qué estoy realizando mal o qué es lo que puede pasar?
    Muchas gracias.

    • Poco te puedo decir de tu hardware porque es muy diferente al mío aunque no creo que tenga que ver con el disco SSD. En tonymacx86 hay un hilo titulado “Mountain Lion on GA X79 UD5 3820 GTX 560 ti” que te puede ayudar.

Los comentarios están cerrados.